mysql

Ansible: The PyMySQL (Python 2.7 and Python 3.X) or MySQL-python (Python 2.X) module is required

Ansible logó
Probléma : fatal: [127.0.0.1]: FAILED! => {"ansible_facts": {"discovered_interpreter_python": "/usr/bin/python3"}, "changed": false, "msg": "The PyMySQL (Python 2.7 and Python 3.X) or MySQL-python (Python 2.X) module is required."}
Azaz hiányzik a pymysql modul.

MySQL: ERROR 1221 (HY000): Incorrect usage of DB GRANT and GLOBAL PRIVILEGES

MariaDB logó
Probléma: Replikációs jogokat akarsz adni MariaDB-ben/MySQL-ben egy felhasználónak, de az alábbi hibaüzenetet kapod:
ERROR 1221 (HY000): Incorrect usage of DB GRANT and GLOBAL PRIVILEGES

Megoldás:A replikációt végző felhasználó nem korlátozható csak egy adott adatbázis hozzáférésére.
Hibás parancs:

FlySpray: ha nem UTF-8 az adatbázis alapértelmezett karakterkódolása

Probléma: Ha a FlySpray telepítése előtt létrehozott adatbázist elfelejtettük alapértelmezetten UTF-8 karakterkódolásra állítani, akkor a legelső latin-2 inkompatibilis karakternél kiakad és vagy badarságot ír be az adatbázisba vagy jobb esetben hibás lesz a lekérdezés.

Munin: Missing dependency Cache::Cache at /etc/munin/plugins/mysql_ line 728.

Munin logo
Probléma: A Munin MySQL plugin a következő hibaüzenetet dobja: Missing dependency Cache::Cache at /etc/munin/plugins/mysql_ line 728.

GreenSQL telepítés és mérési eredmények

Figyelem, retro cikk! Több mint 6(!) éve íródott.
A retro oldalakról bővebben az Így olvasd a retro oldalakat cikkben olvashatsz.

Fontos: A GreenSQL az idők során fizetős lett. Bár e-mail címért cserébe elérhető belőle egy express változat, ez már nem az, amiről a cikk szól.